
LESSON 1 = INTRODUCTION week of January 7

Reading:   Napolitano Chapter 1

Topics:

1- get  Mathematica

2- Notebooks

3- Numbers and operations

4- Exercises

5- Summary

(1) MATHEMATICA

You will be able to use Wolfram Alpha for some simple problems (most of 

Lesson 1) but you will need Mathematica on your laptop for more difficult 

problems.

◼◼ To use Wolfram Alpha, set up a Wolfram ID...

◼ go to URL : www.wolframalpha.com

◼ create a Wolfram ID

◼ create a small file  test.nb

◼ sign out

◼ go to your e-mail message "Wolfram Account" and follow the directions

◼ go to URL: www.wolframcloud.com

◼ click on Cloud Files

◼◼ Instructions for downloading a free Mathematica license and so�ware onto 

your laptop...

◼ Go to the web page at https://cstore.msu.edu, and follow the directions.

◼ Click  So�ware

◼ Student Use  →  search so�ware

◼  Browse → Wolfram → Mathematica

◼ Wolfram Mathematica License → 2019 to August 2020 → add to cart

◼ Go to cart → Checkout

◼ E-mail address ; use your MSU email address



◼ Sign in 

◼ Now fill  out the long form, and continue...

It may take a few days to get the license. Watch your email for a message 

from Wolfram.  Reply.  Then watch your email for a message from the MSU 

computer store. Reply to that.

What is available in Mathematica?

Mathematica is a unified so�ware package that can do many tasks in mathe-

matics:

   ● numerical calculations ⇒ it is like a super calculator

   ● algebra ⇒ symbolic calculations

   ● plotting functions ⇒ graphical analysis of functions

   ● calculus ⇒ derivatives, integrals, differential equations

   ● statistics and data analysis

These tasks are o�en encountered in physics and astrophysics, because 

physics is a mathematical science.

So Mathematica is a powerful tool for students and research scientists in 

physics.

There exist other computer so�ware packages that have some of the same 

capabilities as Mathematica. Examples are MATLAB, Maple, Python. How-

ever, for most practicing physicists, Mathematica is the preferred so�ware. 

The reason is because Mathematica can do many varied tasks in one unified 

package.

Mathematica was originally developed by Steve Wolfram — a theoretical physi-

cist. So physics has always been a central feature of the so�ware. Just about 

anything that physicists need is included in Mathematica.
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(2) Using the Mathematica Notebook Interface

Unlike a programming language, Mathematica is interactive. The interface 

between the user and the computer is called a “Notebook”.

Please understand the interactive nature of Mathematica, compared to a pro-

gramming language:

Suppose you wanted to do a calculation using FORTRAN or C++ or Python 

(programming languages). Then you would need to go through many steps: 

▮ open a text editor and type in the program;

▮ compile the program, i.e., convert the readable source file  into machine 

language;

▮ run the program,  which will produce output in one or more output files;

▮ then open the output file  in a text editor to read the results;

▮ interpret the results using some other so�ware;

▮ write a report with a word processor.

In contrast, Mathematica is interactive. 

You can do all of these steps in one Notebook.

OK, now let’s get started.
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 Open a new Mathematica Notebook.

What do you get?

Out[  ]=

A blank window with a TOOLBAR at the top.

Place the cursor in the blank space; type 2 + 2  and then hit Shift-Enter. Now 

you should have two cells named In[1] and Out[1]. In[1] is an Input Cell, and it 

contains what you typed. Out[1] is an Output Cell and it contains the output 

from Mathematica.

Now place the cursor below Out[1] , and type Plot[Sin[x], {x, 0, 3*Pi}] ; make 

sure you type the square brackets and curly brackets exactly right; hit Shift-

Enter to execute this new Input Cell.

Now you should have 4 cells, named In[1] .. Out[1] .. In[2] .. Out[2].  The input 

cells contain the commands you typed. The output cells contain the Mathemat-

ica responses.

Place the cursor below Out[2]. Type three lines (but do not hit Shift-Enter yet !) 

:
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a = 5

b = 3

Plot[a + b *x, {x, -5, 5}]

A�er  you have typed all three lines, hit Shift-Enter.

What did you get ?

There should be a new Input Cell In[3] with three lines; and three Output Cells 

with responses. Each Output Cell contains the Mathematica response to a 

command in In[3].

OK, now you should have the general idea about how to use the Notebook 

Interface :

▮  In an Input Cell you type one or more commands.

▮  When you are ready, hit Shift-Enter.

▮  Mathematica will execute the commands that you typed and put the 

results into the Notebook as Output Cells. It does not delete the Input Cells; so 

as you work along you accumulate a series of calculations and their results.

To suppress output, end the command line with a semicolon (;).

●

Suppose you have a Notebook with commands and results that you want to 

save.

Click on the button ‘File’ in the TOOLBAR. You'll get a pull-down menu. To 

save the Notebook you are working on,  click ‘Save As’. You will be prompted 

for a name for the file. Save the Notebook to a file  on your flash drive (or on a 

disk drive). Give it a name such as ‘MyNotebook.nb’; or whatever name you 

want with the ending ‘.nb’ .

Now when you close Mathematica, the notebook that you saved is stored on 

your flash drive (or disk drive) . If you want to work on it again later, you can 

open it when you restart Mathematica.
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The Notebook Interface

◆ The TOOLBAR

The TOOLBAR has 10 buttons; click a button; get a pull down menu; click on 

the thing you want to do in the pull down menu. Here are some important 

actions :

Out[  ]=

TOOLBAR COMMANDS purpose

File > Save As save a Notebook with new name

File > Save save a notebook with the current name

File > Open open an existing notebook

File > Print print or print to PDF

Edit > Cut,Copy,Paste cut and paste when editing

Format > Style select a style for a cell

Cell > Divide Cell break a large cell into 2 parts

Cell > Merge Cell merge 2 cells into 1

Evaluate > Evaluate Notebook evaluate all input cells

Evaluate > Abort Evaluation stop all running evaluations

Many other tasks can be done from the TOOLBAR, but those listed above are 

the most common.

A comment about saving your work :

If you are working on a Notebook, SAVE YOUR WORK EVERY SO OFTEN!  If 

the computer crashes, you will lose anything that has not been saved. Do not 

assume that the computer will not crash!  Every few minutes, or each time 

you complete something in a Notebook,  save the Notebook.

◆ The CELL BRACKETS

Note that every cell has a long bracket  (  ]  )  on the right side of the window.  

When you click on the bracket, you "select" that cell.

Then you can do various things with the selection :

▮ delete the cell ⇒ select the cell, and hit the delete button 

▮ merge two cells ⇒ select the two cells; merge them from the Cell TOOL
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▮ cut or copy and paste a cell ⇒ select the cell; cut, paste, copy from  the Edit 

TOOL
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(3) Numbers and Operations

For numerical calculations, Mathematica is a super calculator.

Mathematica can do numerical calculations, such as you could do with a calcu-

lator, but much more powerfully. By default , Mathematica does exact calcula-

tions, whereas your calculator only does approximate calculations to 9 or 10 

significant figures. The calculator is accurate enough for most purposes, but 

Mathematica is easier to use, and more flexible  and more powerful.

Here is an example. Find the solution to this equation: 3 x2 – 5 x – 1 = 0.

First solve the problem with your calculator, and write down the answer.

Now do the calculation using Mathematica. In an Input Cell, type

In[  ]:= ( 5 ± Sqrt[5^2 - 4 *3 * (-1)] ) / (2 *3)

(* and now type Shift-Enter *)

Note that Mathematica gives the exact answer.

If you want a decimal approximation to 15 place accuracy, then  type

In[  ]:= exact = ( 5 + Sqrt[5^2 - 4 *3 * (-1)]) / (2 *3)

approx = N[solution, 15] (* and now type Shift-Enter *)

The result should agree with the result from your calculator.

Example

Solve this equation 7 x2 – 5 x + 1 = 0. Get both the exact answer and a decimal 

approximation to 6 place precision.

In[  ]:= {a, b, c} = {7, -5, +1}

sol = (-b + Sqrt[b^2 - 4*a*c])/(2*a)

N[sol, 6]

Do you see why Mathematica is superior to a calculator?
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Mathematica does exact mathematical calculations.

Mathematica can handle all kinds of numbers:

integers, rationals, irrational roots, transcendentals, complex numbers .

Mathematica can deal with them all.

Your calculator is very limited; it can only handle decimal approximations to 

reals.

Example

Use Mathematica. Type these two numbers on two lines of an Input Cell:

Sqrt[2] and Sqrt[2.0]   ;  then hit Shift-Enter.

You should get two different results. Explain why.

In[  ]:= Sqrt[2]

Sqrt[2.0]

Sometimes we need exact mathematics, but sometimes we only need decimal 

approximations.    Type and execute the Mathematica examples below to get

different kinds of information.

Example

The number π  is a transcendental number.

Use Mathematica to determine 100 digits of π.

(You can use either N[ Pi , 100 ] or SetPrecision[ Pi , 100 ] .)

In[  ]:= N[Pi, 100]

Can you do that with your calculator?

If Mathematica encounters a number that can be simplified, it will simplify 

it.

Example

Use Mathematica to evaluate the square root of 72.

(Type and execute r = Sqrt[72]) . Also, verify that the result is correct by calcu-

lating r*r.
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In[  ]:= r=Sqrt[72]

r*r

Example

Calculate the square root of  42,069,746,374,656.

Then apply the command FactorInteger to reduce the result to integer factors.

(First execute ?FactorInteger in an Input Cell to get help about this

command.)

In[  ]:= big = 42069746374656

sqt = Sqrt[big]

{sqt[[1]], sqt[[2]]}

FactorInteger[ 120736 ]

FactorInteger[ 2886 ]

The answer is ...

42, 069, 746, 374, 656  

= 25 ▫ 73 ▫ 11 ▫ 2 ▫ 3 ▫ 13 ▫ 37
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(4) Exercises

Now do the exercises below to get some practice using Mathematica com-

mands.

By doing these exercises, you will begin to learn how to use Mathematica as a 

super calculator.

Remember : save your work in case of a computer crash. 

 Exercise 1. Calculate the square root of 13. 

Type Sqrt[13], hit Shift-Enter.

 Exercise 2. Calculate the decimal approximation of the square root of 13,

accurate to 10 significant figures.

 Exercise 3. Calculate the cosine of 1 radian. 

Type Cos[1], hit Shift-Enter.

 Exercise 4. Calculate the decimal approximation of the cosine of 1 radian,

accurate to 10 significant figures.

 Exercise 5. Calculate the two solutions of the equation  11 x2 + 13 x + 17 = 0.

Type Solve[ 11*x^2 + 13*x + 17 == 0 , x ].

 Exercise 6. Calculate the two solutions (for x) of the equation    A x2 + B x + C = 

0 

where A, B, C are unspecified constants.

 Exercise 7. Calculate the prime factors of 579.

The next three questions are examples from physics.

 Exercise 8. Imagine that you drop a small mass (m = 0.27 kg) from a tower 10 

meters high, in Earth’s gravity. Calculate the time when the mass will hit the 

ground, neglecting the effect of air resistance.

 Exercise 9. One particle is moving on the x axis with constant velocity  v1 x = 5 

m/s, and is decelerating with a1 x = – 1 m  s2. A second particle is moving paral-

lel to the x axis, with y = 0.5 m. (It might help to sketch a picture.)

At time t = 0 :

the two particles are both at x = 0 ;
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the second particle has velocity v2 x = 0;

and a�er  t = 0 the second particle accelerates with a2 x = + 2 m  s2.

Find the position xpass where the second particle will pass the first particle.

Hint: Use the command Solve. First write expressions for x1 and x2 and then

execute Solve[x1==x2,t].

 Exercise 10. Calculate the mean speed of the Earth as it revolves around the 

sun. Express the answer in km/s and use appropriate significant figures.

Hints: The mean radius of the Earth’s orbit is 149.6 x 106 km. You can enter the 

number into Mathematica as either 149.6*^6 or 149.6*10^6. The period of revo-

lution is 365.25 days.

(5) Summary of Lesson 1

Now you should understand:

- Exact numbers and decimal approximations

- The function Sqrt[x]

- The function Cos[x]; x is in radians

- The commands N[ r ,d ] and SetPrecision[ r ,d ]

- Every Mathematica command starts with a capital letter.

- Every built-in Mathematica function starts with a capital letter.

- For every Mathematica function, the independent variable is enclosed 

in square brackets. 

- To get help,  ?Command

12



In[  ]:= ?Sqrt

?Cos

?N

Out[  ]=

Symbol

Sqrt[z] or z gives the square root of z.

Out[  ]=

Symbol

Cos[z] gives the cosine of z.

Out[  ]=

Symbol

N[expr] gives the numerical value of expr.

N[expr, n] attempts to give a result with n-digit precision.
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